Usando o Foxit Reader? Você Pode Ser Vulnerável às Violações da Rede

Cibersegurança e ciberataques tornaram-se tópicos de destaque ultimamente. Não importa o quanto você garante a segurança de sua rede, as vulnerabilidades continuam a surgir para diferentes sistemas operacionais e aplicativos. Mais recentemente, profissionais de segurança descobriram duas vulnerabilidades críticas em um aplicativo de leitura de PDF de terceiros chamado Foxit Reader. Essas vulnerabilidades permitem que os hackers executem código definido arbitrariamente no computador de um usuário quando o Foxit Reader é usado sem o modo de leitura seguro ativado.

Duas vulnerabilidades críticas do dia zero

Em 17 de agosto, os pesquisadores Steven Seeley e Ariele Caltabiano descobriram duas vulnerabilidades no Foxit Reader:

1. CVE-2017-10951, que atua como um bug injeção de comandos que reside na função app.launchURL e executa strings fornecidos por hackers. Essa vulnerabilidade deve-se principalmente a uma validação incorreta.

2. CVE-2017-10952, que existe na função saveAs e permite que os hackers executem um arquivo arbitrariamente especificado nos computadores do usuário. Se o arquivo arbitrário for modificado, os hackers podem modificar qualquer coisa no computador do usuário final. Steven Seeley testou uma prova de conceito e publicou-a no Zero Day Initiative.

Como você pode manter o Foxit Reader seguro?

1. Tome p recautions : Evite baixar anexos de endereços de e-mail que você não conhece. Abrir um PDF de um remetente nefasto pode comprometer todo o seu sistema.

2. Alterar manualmente as configurações : se você está usando Foxit Reader ou Foxit Phantom PDF, vá para o menu de configurações e ative o Modo de leitura segura e desmarque Ativar JavaScript .

3. Empregar o gerenciamento automático de patches: fazer todo o trabalho manual é cansativo e complicado, especialmente porque o número de vulnerabilidades por aplicativo aumenta continuamente. Atualizar regularmente é uma das melhores maneiras de permanecer livre de vulnerabilidades do dia zero. Mantenha-se vigilante empregando software de gerenciamento de patches como o Desktop Central, que administra e implanta patches automaticamente.

Como a ManageEngine Ajuda?

O ManageEngine oferece dois tipos de suporte para essas vulnerabilidades do Foxit Reader:

1.Patch deployment

O Desktop Central pode reparar Windows, Mac, Linux e mais de 250 aplicativos de terceiros, todos de uma localização central. A ManageEngine lançou uma atualização especificamente para produtos Foxit para ativar automaticamente o modo de leitura segura em aplicativos Foxit PDF.

 

2. Configuração do Registro

Com o Desktop Central, você pode implantar configurações de registro específicas, incluindo as chaves específicas do Foxit abaixo, para computadores gerenciados:

Chave para ativar o Modo de leitura segura:
HKEY_CURRENT_USER \ Software \ Foxit Software \ Foxit Reader 8.0 \ Preferences \ TrustManager
bSafeMode = 1 (Ativar modo de leitura segura)
bSafeMode = 0 (Desativar o modo de leitura segura)

Chave para desmarcar Ativar ações de JavaScript:
HKEY_CURRENT_USER \ Software \ Foxit Software \ Foxit Reader 8.0 \ Preferences \ Others
bEnableJS = 1 (Ativar ações do JavaScript)
bEnableJS = 0 (Desativar ações de JavaScript)
Comece a usar o Desktop Central hoje para evitar vulnerabilidades e violações acontecendo em qualquer aplicativo de terceiros.

Venha conhecer o ManageEngine Desktop Central, contando sempre com apoio da equipe ACSoftware.

Fone: (11) 4063 9639

Deixe um comentário